Welcome, Guest. Please login or register.
Did you miss your activation email?
24 August 2017 à 08:07:32
Home Help Search Login Register
News:

[EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU]
+  Forum de Plici, solution ecommerce open source
|-+  Plici Open Source Ecommerce Solution
| |-+  Installation
| | |-+  Problème lancement mysql
« previous next »
Pages: [1] Print
Author Topic: Problème lancement mysql  (Read 16394 times)
windfly
Newbie
*
Posts: 2



View Profile
Problème lancement mysql
« on: 11 September 2009 à 19:48:45 »

Bonjour à tous,

J'ai bien réussi à tout installer et j'ai même réussi à créer quelques pages sur mon site.
Mais le lendemain, en voulant continuer mon site, je lance xampp (pas de soucis), je démarre apache (running, donc pas de problème) mais impossible de lancer mysql.

La fenetre de commande dessous indique : Mysql started [port 3306] busy

J'ai tenté de relancer la machine, de déconnecter tous les programmes ayant accès à internet, mais rien de plus.

Pouvez vous m'aider?

Merci d'avance

Guillaume
Logged
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : Problème lancement mysql
« Reply #1 on: 17 September 2009 à 13:35:12 »

Cela peut venir de la case à cocher à côté de la zone start Mysql.

Il faut la cocher, décocher, cocher, décocher.

En fait cela va forcer la désinstallation du service Mysql (que tu avais peut être réalisée pour un autre système avant).

Et comme ça ce xamp pourra lancer son Mysql.
Logged

PliciWeb Solutions : http://www.pliciweb.com.
RASBAT
Newbie
*
Posts: 1



View Profile Email
Re : Problème lancement mysql
« Reply #2 on: 20 March 2010 à 21:07:54 »

J'ai rencontré le meme probleme lorsque je me suis connecté la deuxieme fois pour continuer à mettre à jour mon site. En effet, le serveur SQL est toujours busy, Mysql started [port 3306] busy
malgré que je coche décoche coche décoche, rien à faire. Je suis bloqué alors que j'en suis qu'au tout début.
A l'aide!!!!
Logged
yann2104
Newbie
*
Posts: 4



View Profile
Re : Problème lancement mysql
« Reply #3 on: 11 December 2010 à 11:46:43 »

Idem, toujours le même problème. Quelqu'un a-t-il une solution?

Merci!!
Logged
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : Problème lancement mysql
« Reply #4 on: 14 December 2010 à 10:29:52 »

Bonjour,

Avez-vous cherché un peu si le programme est déjà lançé dans le gestionnaire des tâche ?
Si ce n'est pas un service installé ?

Car là, en fait vous n'arrivez pas à installer EasyPhp ou autre, du coup c'est même pas du plici, c'est bien ça ?

Stéphane,
Logged

PliciWeb Solutions : http://www.pliciweb.com.
Luc
Newbie
*
Posts: 11



View Profile
Re: Problème lancement mysql
« Reply #5 on: 04 August 2011 à 20:49:28 »

Bonjour,

Moi aussi, je me trouve confronté au même type de panne que Windfly (circonstances et scénario identiques à 100 %).

Comme Rasbat, le fait de cocher et de décocher à l'infini la case à côté de la zone "Start" de Mysql  du panneau de contrôle de XAMPP ne déclenche pas son "running" (sauf de façon aléatoire et très éphémère).

Je me retrouve donc, comme Yann2104, totalement bloqué…

Pour répondre à Stéphane sur les indications données par le gestionnaire des tâches de Windows, seul l'appli "XAMPP Control Panel Application" est en cours d'exécution.

J'ajoute qu'à chaque démarrage de l'ordi (système Vista Pro) comme pour Emma avec son Windows XP SP2 (http://forum.plici.net/developpement/%28resolu%29xampp-lite/, post du 21 avril 2009), je reçois le même message d'erreur indiquant une violation d'adresse dans le module LIBMYSQL.dll, message qui se réitère à l'infini et qu'on ne parvient à stopper que par le biais du gestionnaire des tâches.

Même remarque qu'Emma également : "en tapant l'url http://localhost, un point d'interrogation s'affiche dans le navigateur".

La solution indiquée par Emma permettant de créer la clé XAMPP manquante dans la base des registres n'a généré aucun effet apparent dans mon cas.

Concernant le point d'interrogation qui s'affiche dans le navigateur en tapant l'url http://localhost je n'ai pas retrouvé, dans le forum, la solution évoquée par Emma, solution, toutefois et à ses dires, sans lendemain ; je regrette donc qu'elle n'ait pas mentionné sa source pour tester, à mon tour, cette piste.

Enfin, les voies de sortie données par Ace qui répondait à Emma ne sont pas de nature à régler le problème de façon nette, elles sont plutôt évacuantes.

Je suis bien d'accord avec la réponse de Stéphane à Emma lorsqu'il précise qu'il suffit de lancer le "Windows Installer", suivre ses directives et lorsque que le panneau  de contrôle de XAMPP apparait à l'écran, lancer (Start) Apache (qui déclenche son "Running") puis MySql ("Running" également et sans problème) et, dans ces conditions, effectivement, en se connectant sur http://localhost/, on obtient bien un site PLICI en bon état de fonctionnement.

Seulement voilà, la procédure décrite par Steph ne marche qu'une seule fois (enfin, dans mon cas et celui de Windfly, Rasbat et Yann2104) c'est à dire au moment de notre première installation en lançant l'exe du Windows Installer (Plici_2.0.0.Stable.r.1878_Windows_Installer, dans mon cas). Par contre, à chaque reboot de l'ordi, si je fais C:/Program Files/Plici/xampplite/xampp-control (.exe) et que je lance cette dernière appli, le "Running" de MySql fait la sourde oreille ! (Même en ne faisant pas taire l'insupportable message d'erreur répétitif indiquant une violation d'adresse dans le module LIBMYSQL.dll dont j'ai parlé plus haut lors du reboot de l’ordi).

Je pourrais bien sûr envisager de tout désinstaller et de relancer toute l'installation en faisant appel aux bons (?) offices de  Plici_2.0.0.Stable.r.1878_Windows_Installer, mais au prochain reboot ? (sans compter l'éventuelle disparition de mon travail antérieur pour la construction de mon site).

Les pertes de temps occasionnées par ces errances de fonctionnement sont évidemment regrettables mais je les accepte avec courage et bonne volonté car c'est le franc jeu de l'open-source, je serais donc vraiment navré si mes remarques concernant ces dysfonctionnements devaient entamer la bonne humeur de ceux qui me liront.

Luc
« Last Edit: 06 August 2011 à 01:51:03 by Luc » Logged
Luc
Newbie
*
Posts: 11



View Profile
Re: Problème lancement mysql
« Reply #6 on: 05 August 2011 à 23:50:56 »

Bonjour,

Comme il faut bien avancer pour sortir de cette impasse, voilà ce que j’ai fait :

J’ai commencé par stopper l’activité de la base de données MySql  à partir de son fichier de commande « msql_stop »  (chemin C:/Program Files/Plici/xampplite/msql_stop (.bat) )

Puis  j’ai relancé MySql  avec la commande « msql-start » (même chemin)

Réaction immédiate du soft qui brandit le panneau informatif  « C:\Windows\system32\cmd.exe » suivant :

______________________________________________________________________________

Diese Eingabeforderung nicht waehrend des Running beenden
Please dont close Window while MySQL is running
MySQL is trying to start
Please wait  ...
MySQL is starting with mysql\bin\my.cnf (console)
110805 11:43:49 [Warning] Can't create test file C:\Program Files\Plici\xampplit
e\mysql\data\PC-de-Luc.lower-test
110805 11:43:49 [Warning] Can't create test file C:\Program Files\Plici\xampplit
e\mysql\data\PC-de-Luc.lower-test
110805 11:43:49 [ERROR] mysql\bin\mysqld: Can't create/write to file 'C:\Program
 Files\Plici\xampplite\mysql\data\PC-de-Luc.pid' (Errcode: 13)
Can't start server: can't create PID file: Permission denied

MySQL konnte nicht gestartet werden
MySQL could not be started
Appuyez sur une touche pour continuer...



______________________________________________________________________________

(L’action de la touche « pour continuer » est destinée à fermer la fenêtre du message)

Pendant la manœuvre de réactivation de MySql  un « Running » situé en face de la case « Start » de MySql du panneau de contrôle de XAMPP est apparue une fraction de seconde seulement.

Je vois bien en lisant le message qu’il y a un problème de création de fichier à la base de mes ennuis mais comme je n’ai pas étudié l’informatique je me sens vraiment démuni, si quelqu’un dans le forum pouvait me donner une piste ça me ferait très plaisir.

Merci d’avance,

Luc
« Last Edit: 05 August 2011 à 23:54:34 by Luc » Logged
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : Problème lancement mysql
« Reply #7 on: 06 August 2011 à 09:47:08 »

En fait ce problème est uniquement du au fait que vous avez déjà installé mysql en tant que service.
Hors il n'est pas possible de lancer 2 fois mysql en même temps.
Ce qu'il faut c'est couper l'autre sql avant.
il faut chercher dans les services Windows votre autre mysql et le stopper me temps de lancer celui de plici.

J'espère que ça aide.

Stéphane
Logged

PliciWeb Solutions : http://www.pliciweb.com.
Luc
Newbie
*
Posts: 11



View Profile
Re: Problème lancement mysql
« Reply #8 on: 08 August 2011 à 23:02:00 »

Bonjour Stéphane et merci pour ta réponse. Oui, elle m’a aidé car elle m’a permis de ne pas rester les bras croisés à me morfondre. Parti à la poursuite de mon autre MySql, ces recherches m’ont conduit à sortir de mon blocage c’est à dire de pouvoir accéder de nouveau  à l’adresse http://localhost/   Smiley. Toutefois, je ne prétends pas avoir trouvé la juste solution (eurêka !) mais, concrètement, puisque cela fonctionne, je suis satisfait.
 
Je ne sais pas si je dois inscrire « RESOLU » sur ce post, d’abord parce que je n’en suis pas l’auteur (en tous cas je n’en suis pas à l’origine) et d’autre part, parce que la solution qui a fonctionné chez moi n’est peut-être pas transmissible chez un autre, sans compter que mes « manips » (n’étant pas informaticien) ne correspondent surement pas une démarche informatique digne de ce nom. Le fait est que j’ignore les raisons pour lesquelles cela fonctionne  Grin.

Je pense, cependant, qu’il n’est peut-être pas inintéressant d’expliquer ce que j’ai fait, à condition que l’on ait bien compris que je ne revendique aucune compétence en la matière.

Dans un premier temps j’ai tenu compte du fait que tu m’avais dit que j’avais probablement dans mon ordi un autre MySql qui entrait en concurrence avec celui généré par XAMPP et que je devais absolument le faire taire si je voulais lancer le MySql de PLICI. Ca m’a étonné parce que je n’avais le pas souvenir d’avoir installé un autre MySql.
 
Je suis donc parti à la recherche de l’intrus, notamment dans les services Windows, mais je n’ai rien trouvé, c’est vrai aussi que je me suis un peu perdu dans ces recherches.

Toutefois, lors de ma toute première installation de PLICI je me suis souvenu que j’avais un peu pataugé avec le panneau de contrôle de XAMPP et que pour obtenir le fameux « Running » des 2 modules Apache et MySkl  j’avais appuyé un peu sur tous les boutons à la fois  Grin. J’ignore si ces errements ont eu des conséquences négatives pour la suite des évènements c’est à dire si elles ont pu générer un MySql supplémentaire …  Huh

Je suis donc parti sur cette supposition et après avoir sauvegardé mes données, j’ai désinstallé PLICI puis j’ai rebooté. RAS. Ensuite, j’ai réinstallé PLICI et là nickel, tout a fonctionné comme au premier jour. Reboot pour vérifier si mes ennuis précédents allaient recommencer. Hélas, même scénario ! Pendant la période de réinitialisation j’ai pu noter la survenue éphémère d’un panneau plein d’onglets portant le logo My SQL et ayant pour titre « WinMySqlAdmin 1.4 ». Puis, vers la fin du reboot, cette appli s’est remise à déverser sa cascade ininterrompue d’avertissements : « Access violation at adress 10009F40 in module « LIBMYSQL.dll ».Read of address 00000000 ».

Pour moi, cette appli constituait peut-être une piste à suivre ? J’ai fini par la dénicher au fond du chemin suivant : C:\Programmes\Plici\xampplite\mysql\bin. Mauvaise et bonne surprise en même temps ! La mauvaise c’est qu’en ouvrant le programme (sa fenêtre apparait une ou deux secondes puis s’évanouit), la calamiteuse invasion d’avertissements  « Access violation at adress 10009F40 in module « LIBMYSQL.dll ».Read of address 00000000 » s’est remise en route ! La bonne c’est  que le panneau de contrôle de XAMPP s’est subitement modifié ! La case « Svc » de MySql s’est auto-cochée et son « running » sur fond vert est apparu sans que j'en fasse la demande ! ! ! J’ai profité de l’aubaine et j’ai lancé à son tour le serveur Apache. Fier de mes deux « Running », j’ai collé l’adresse  http://localhost sur mon navigateur et PLICI m’a répondu présent ! Super !

Tour content, je reboote et là, demi-drame, les exécrables avertissements sont de retour, par contre, en cliquant sur le raccourci de XAMPP du menu Démarrer, le panneau de contrôle apparaît avec sa case « Svc » de MySql pré-cochée et son « Running » déjà prêt pour le combat. Je lance Apache… ouvre mon navigateur…  http://localhost me répond !

J’ai fait plusieurs reboot, plusieurs réinstallations, rien ne change, le scénario que je viens de décrire reste immuable. Comment me débarrasser de ces « Access violation » ? ? ?  La prière sans doute, j’ai donc pesté contre ce mauvais dieu Windows qui s’en est ému et à guidé mon index sur le panneau des propriétés de « winmysqladmin », puis sur l’onglet « compatibilité » pour me faire entrer  dans le lieu saint des « privilèges » afin de me suggérer d’ « Exécuter ce programme en tant qu’administrateur » ! Je me suis empressé, bien entendu, de répondre « OK »…

… Le cauchemar des violations d’accès n’est plus jamais revenu !!!

Aujourd’hui je suis un internaute heureux et je travaille avec empressement sur la construction de ma future boutique !  Cool Cool Cool

Luc
Logged
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : Problème lancement mysql
« Reply #9 on: 08 August 2011 à 23:22:01 »

Je suis ravi que tu es trouvé la solution.
Et jamais, au grand Jamaïque n'aurai pensé aux droits administrateur.

Félicitations !
Logged

PliciWeb Solutions : http://www.pliciweb.com.
Luc
Newbie
*
Posts: 11



View Profile
Re: Problème lancement mysql
« Reply #10 on: 08 August 2011 à 23:26:00 »

C’est un compliment qui me fait rougir et que je ne mérite surement pas, mais qu’est-ce que j’en suis fier !!!
Logged
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : Problème lancement mysql
« Reply #11 on: 08 August 2011 à 23:34:24 »

Désolé pour le Jamaïque,  j'ai écrit de mon tel.
Encore félicitations et welcome!!
Logged

PliciWeb Solutions : http://www.pliciweb.com.
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!