Welcome, Guest. Please login or register.
Did you miss your activation email?
24 November 2017 à 12:24:24
Home Help Search Login Register
News:

[EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU]
+  Forum de Plici, solution ecommerce open source
|-+  Plici Open Source Ecommerce Solution
| |-+  Developers
| | |-+  [Résolu] Bouton commander ne fonctionne pas
« previous next »
Pages: [1] 2 Print
Author Topic: [Résolu] Bouton commander ne fonctionne pas  (Read 17603 times)
yann9477
Newbie
*
Posts: 13



View Profile WWW
[Résolu] Bouton commander ne fonctionne pas
« on: 26 March 2010 à 12:16:12 »

Bonjour,

J'ai un souci lorsque je souhaite finaliser une commande le bouton commander ne fonctionne pas, je ne comprend pas J'utilise le theme 2 plici

Est ce que quelqu'un peu m'aider, SVP?
Je joint un screenshot
« Last Edit: 02 April 2010 à 15:18:06 by yann9477 » Logged

En pleine découverte de plici...
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : Bouton commander ne fonctionne pas
« Reply #1 on: 30 March 2010 à 08:39:21 »

Tu n'aurais pas une erreur javascript ?
Logged

PliciWeb Solutions : http://www.pliciweb.com.
yann9477
Newbie
*
Posts: 13



View Profile WWW
Re : Bouton commander ne fonctionne pas
« Reply #2 on: 30 March 2010 à 13:30:16 »

Je ne sais pas, car je n'arrive pas à bien voir l'arborescence des pages.
Logged

En pleine découverte de plici...
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : Bouton commander ne fonctionne pas
« Reply #3 on: 30 March 2010 à 15:03:25 »

le plugin firebug de firefox ne t'aide pas ?
Logged

PliciWeb Solutions : http://www.pliciweb.com.
yann9477
Newbie
*
Posts: 13



View Profile WWW
Re : Bouton commander ne fonctionne pas
« Reply #4 on: 30 March 2010 à 15:32:38 »

A priori je n'ai aucun pb avec java puisque sur le reste java fonctionne sauf la. Je ne comprend vraiment pas...

Voici le code source que j'ai:
Quote
<div class="btn_common_position">
            



<div class="nodisplay" id="btn_common_22cb7ca7a50795f2929783e5cf2f01dc">       <div class="sw_bt_gauche"><img width="22" height="59" alt="" src="/picture/bouton/bt_gauche.jpg"></div>      <div class="sw_bt_centre"><a href="/l1/p18-customer.html">Commander</a></div>      <div class="sw_bt_droite"><img width="22" height="59" alt="" src="/picture/bouton/bt_droite.jpg"></div></div>
<input type="submit" value="Commander" id="btn_common_22cb7ca7a50795f2929783e5cf2f01dc_without_js"><script type="text/javascript" language="javascript">            //&lt;![CDATA[               toVisibleInline('btn_common_22cb7ca7a50795f2929783e5cf2f01dc');               toNotVisibleInline('btn_common_22cb7ca7a50795f2929783e5cf2f01dc_without_js');            //]]&gt;</script>                       
      </div>
« Last Edit: 30 March 2010 à 16:08:26 by yann9477 » Logged

En pleine découverte de plici...
yann9477
Newbie
*
Posts: 13



View Profile WWW
Re : Bouton commander ne fonctionne pas
« Reply #5 on: 01 April 2010 à 14:56:14 »

Est-ce que quelqu'un peut m'aider, car je ne trouve pas la solution au pb...

Par avance, je vous remercie.
Logged

En pleine découverte de plici...
fmallet
Bêta Testeur
Sr. Member
**
Posts: 354



View Profile WWW Email
Re : Bouton commander ne fonctionne pas
« Reply #6 on: 01 April 2010 à 15:11:51 »

Ca peux venir aussi du CSS si celui ci est pas bien configuré. Le mieux c'est de prendre firebug de firefox et de voir la classe/id de style qui pose probleme et de l'enlever pour verifier.

Fred
Logged
yann9477
Newbie
*
Posts: 13



View Profile WWW
Re : Bouton commander ne fonctionne pas
« Reply #7 on: 01 April 2010 à 15:18:04 »

A savoir que le thème utilisé est le theme 2 deja present dans le "pack". Je ne l'ai pas créé ni modifié. firebug ne me donne aucune erreur.
Logged

En pleine découverte de plici...
fmallet
Bêta Testeur
Sr. Member
**
Posts: 354



View Profile WWW Email
Re : Bouton commander ne fonctionne pas
« Reply #8 on: 01 April 2010 à 20:52:48 »

Ce n'est pas une erreur au sens CSS mais plutot une mauvaise programmation qui fait que le "lien" sort de la page affichée ou de l element. Il faut regarder en enlevant le style de la class/id de cet element par Firebug.
Logged
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : Bouton commander ne fonctionne pas
« Reply #9 on: 02 April 2010 à 09:36:12 »

c'est un site accessible de l'extérieur ?
Logged

PliciWeb Solutions : http://www.pliciweb.com.
yann9477
Newbie
*
Posts: 13



View Profile WWW
Re : Bouton commander ne fonctionne pas
« Reply #10 on: 02 April 2010 à 15:17:26 »

J'ai trouver l'erreur sur "css_screen.css" dans le thème. C'est une variable que nous ne devons, normalement pas enlever mais qui plantait la page en question.
Logged

En pleine découverte de plici...
yann9477
Newbie
*
Posts: 13



View Profile WWW
Re : [Résolu] Bouton commander ne fonctionne pas
« Reply #11 on: 02 April 2010 à 15:27:29 »

Je vous joint le fichier rectifié
Il va dans /view/sites/for_plici/theme2com_site/
Logged

En pleine découverte de plici...
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : [Résolu] Bouton commander ne fonctionne pas
« Reply #12 on: 03 April 2010 à 10:40:18 »

parfait !

Il ne manque plus que la dernière étape.
Peux tu créer cette amélioration sur le bugtracker et ensuite on l'affectera vers la nouvelle versions de plici.
penses a faire un lien dans la description vers ce topic du forum.

Comme ça quand on release on fait le tour de ces éléments et on les intègre.

Si tu veux on peut même te donner un accès a svn et que tu puisses developper et valider tes modifications directement sur le serveur.
Logged

PliciWeb Solutions : http://www.pliciweb.com.
Dj Ultimate
Newbie
*
Posts: 4



View Profile Email
Re: [Résolu] Bouton commander ne fonctionne pas
« Reply #13 on: 17 February 2011 à 19:12:48 »

bonjour
mois ca ne fonctionne toujours pas meme avec cette modif sur le theme 2, le bouton commander reste définitivement muet !!
Logged
stephanet
Membre editeur de la solution Plici
Administrator
Hero Member
*****
Posts: 2047


stephane.trichet@free.fr
View Profile WWW Email
Re : [Résolu] Bouton commander ne fonctionne pas
« Reply #14 on: 19 February 2011 à 11:45:57 »

quelle version de Plici ?
Logged

PliciWeb Solutions : http://www.pliciweb.com.
Pages: [1] 2 Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!